Forums

Sega Master System / Mark III / Game Gear
SG-1000 / SC-3000 / SF-7000 / OMV
Home - Forums - Games - Scans - Maps - Cheats - Credits
Music - Videos - Development - Hacks - Translations - Homebrew

View topic - Master System 1 display issues

Reply to topic
Author Message
  • Joined: 13 Nov 2020
  • Posts: 4
Reply with quote
Master System 1 display issues
Post Posted: Fri Nov 13, 2020 10:31 pm
Hello there, I'm Vivian, this is my first time on the forum!

I picked up a European SMS 1 a week or so ago, and recently got the AV cables. However, after plugging in my system all I get is flashing coloured bars.

These change depending on the cartridge inserted (all PAL carts) but I cannot get a recognizable image and there is no sound to speak of. An example is attached.

I'm using a PAL television (although I currently live in North America) and I'm using a power converter for the plug. Is it a fault of the power cable or video? I'm stuck for answers I'm afraid.

Any help will be much appreciated - I was told this was a French system, so I'm unsure if it requires SECAM (which my television may support...) or one of the PAL variants that cause a lot of trouble.

  View user's profile Send private message
  • Joined: 05 Sep 2013
  • Posts: 2790
Reply with quote
Post Posted: Mon Nov 16, 2020 10:12 am
Vivian wrote
recently got the AV cables. However, after plugging in my system all I get is flashing coloured bars.


describe your cables so that we can see if you're over RF or RGB
  View user's profile Send private message Visit poster's website
  • Joined: 14 Aug 2000
  • Posts: 576
  • Location: Adelaide, Australia
Reply with quote
Master System 1 display issues
Post Posted: Tue Nov 17, 2020 2:32 am
What does the sticker on the bottom of the Console say where the model number and serial number is written?

It should say something like "SEGA MASTER SYSTEM Power Base PAL". The last word is the display type e.g. NTSC, or PAL-G, etc...
  View user's profile Send private message
  • Joined: 13 Nov 2020
  • Posts: 4
Reply with quote
Post Posted: Fri Nov 20, 2020 4:04 am
sverx wrote
Vivian wrote
recently got the AV cables. However, after plugging in my system all I get is flashing coloured bars.


describe your cables so that we can see if you're over RF or RGB


One yellow cable, one white cable.
  View user's profile Send private message
  • Joined: 13 Nov 2020
  • Posts: 4
Reply with quote
Post Posted: Fri Nov 20, 2020 4:06 am
asynchronous wrote
What does the sticker on the bottom of the Console say where the model number and serial number is written?

It should say something like "SEGA MASTER SYSTEM Power Base PAL". The last word is the display type e.g. NTSC, or PAL-G, etc...


It reads, "Sega Master System Power Base PAL-G"
Model no. is 3005-18-B.
  View user's profile Send private message
  • Joined: 14 Aug 2000
  • Posts: 576
  • Location: Adelaide, Australia
Reply with quote
Post Posted: Fri Nov 20, 2020 12:19 pm
Ok, the SMS is outputting PAL, and your connecting via composite video which rules out some tuning issues.

So are you sure your TV supports PAL-G? In your part of the world the TV may be PAL-N or PAL-M which AFAIK are not compatible.
  View user's profile Send private message
  • Joined: 05 Sep 2013
  • Posts: 2790
Reply with quote
Post Posted: Fri Nov 20, 2020 3:04 pm
asynchronous wrote
your connecting via composite video which rules out some tuning issues.


yes, it's composite I'd say and I would check if the TV supports 240p / 288p as not many modern screens do that
  View user's profile Send private message Visit poster's website
  • Joined: 13 Nov 2020
  • Posts: 4
Reply with quote
Post Posted: Tue Nov 24, 2020 10:41 pm
asynchronous wrote
Ok, the SMS is outputting PAL, and your connecting via composite video which rules out some tuning issues.

So are you sure your TV supports PAL-G? In your part of the world the TV may be PAL-N or PAL-M which AFAIK are not compatible.


My television is from the UK, and as far as I can tell it should be compatible with PAL-G? I'll have to check for the 240/288p compatibility.
  View user's profile Send private message
  • Joined: 05 Sep 2013
  • Posts: 2790
Reply with quote
Post Posted: Wed Nov 25, 2020 10:59 am
So I would say:
- your TV might be PAL, since you can see the colors (so it's somewhat getting the color sub-carrier)
- your TV might be PAL-I as it's from UK, the SMS it's PAL-G so that might explain why you don't get any audio
- your TV might not support 240p / 288p and that's why it fails to sync the image and just draws lines of color all around
  View user's profile Send private message Visit poster's website
Reply to topic



Back to the top of this page

Back to SMS Power!