Forums

Sega Master System / Mark III / Game Gear
SG-1000 / SC-3000 / SF-7000 / OMV
Home - Forums - Games - Scans - Maps - Cheats - Credits
Music - Videos - Development - Hacks - Translations - Homebrew

View topic - in_vgm 0.35 released

Reply to topic
Author Message
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13689
  • Location: London
Reply with quote
in_vgm 0.35 released
Post Posted: Fri Aug 24, 2007 11:46 am
Last edited by Maxim on Thu Jan 22, 2015 9:59 am; edited 4 times in total
Downloads:
Zipped
Self-installing
Source

Lots of new features, most notably:
- native transcoding support so you can drag and drop VGM files onto your iPod and they'll automatically get converted for you
- Replay Gain support to cancel volume differences between games
- VGM7z support - this is a new, smaller VGM distribution format that I'm hoping will ease the pain of downloading Mega Drive sets.

Comments welcome.

Edit: added screenshots of the config dialogue for those who are interested to see what's been added.
untitled1.png (19.15 KB)
Playback
untitled1.png
untitled3.png (20.87 KB)
GD3 tags
untitled3.png
untitled4.png (16.54 KB)
SN76489
untitled4.png
untitled5.png (17.7 KB)
YM2413
untitled5.png
untitled6.png (14.28 KB)
YM2612
untitled6.png
untitled7.png (12.15 KB)
YM2151
untitled7.png
untitled8.png (14.88 KB)
VGM7z
untitled8.png

  View user's profile Send private message Visit poster's website
  • Joined: 01 Feb 2004
  • Posts: 1462
  • Location: Sunny ol Tamworth, New England NSW AU
Reply with quote
Post Posted: Fri Aug 24, 2007 3:07 pm
Maxim wrote
Lots of new features, most notably:
- native transcoding support so you can drag and drop VGM files onto your iPod and they'll automatically get converted for you


What format does it transcode into (m4a) or mp3, I have a Creative Zen Vision M so will this work, or does the feature only work with iPods?
  View user's profile Send private message Visit poster's website
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13689
  • Location: London
Reply with quote
Post Posted: Sat Aug 25, 2007 2:24 pm
Anything Winamp supports - I use m4a, I know there are OGG and FLAC plugins. Winamp demands money for MP3 unfortunately... if WInamp supports your portable media player, you can drag and drop to transcode and send to the device.
  View user's profile Send private message Visit poster's website
Warpstar
  • Guest
Reply with quote
Post Posted: Mon Aug 27, 2007 11:38 am
Unless I'm doing something wrong, the "Overdrive" function doesn't seem to work in this new version.

ReplayGain is proving to be a bit of a pain to work with as a replacement. For example, it doesn't work at all with SMS FM sets; it tells me the gain is +64 every time, and then plays back nothing but staticy-sounds.
 
Warpstar
  • Guest
Reply with quote
Post Posted: Mon Aug 27, 2007 12:08 pm
Actually, though, the YM2612 really doesn't need the boosting that much, now that I look again (aside from the few odd sets like After Burner II). But the PSG and the YM2413 are too quiet; even if I max out the preamp, they're still way quieter than pretty much anything else.
 
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13689
  • Location: London
Reply with quote
Post Posted: Mon Aug 27, 2007 12:14 pm
1. Yes, it looks like I disabled Overdrive. Oops. I turned it back on and it seems fine. Of course, it is a bad idea to leave it on if using Replay Gain.
2. It looks like the Replay Gain-compatible part is not doing YM2413 properly. I'll look into it.
3. Why did nobody notice this in a year of beta testing? :(
4. YM2612 tracks vary a lot. Striker is 25dB louder than Richard Scarry's Busytown; the PSG only has a dynamic range of 30dB between its quietest and loudest levels. This was the primary reason why Replay Gain was needed.
  View user's profile Send private message Visit poster's website
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13689
  • Location: London
Reply with quote
Post Posted: Mon Aug 27, 2007 2:45 pm
I figured out the bug - a few TODOs I didn't DO yet.

Here's a beta that works:

http://www.smspower.org/maxim/forumstuff/in_vgm_latest/in_vgm.zip

I'll make a release soon with fixes. It turns out I didn't write the code to apply the user's specified chip volumes, so it was defaulting YM2413 to 0. Now it defaults to 100%, I'll make it work properly ASAP.
  View user's profile Send private message Visit poster's website
  • Joined: 18 Aug 2006
  • Posts: 60
Reply with quote
Post Posted: Tue Aug 28, 2007 2:22 pm
Last edited by Yawackhary on Fri Aug 31, 2007 7:04 pm; edited 1 time in total
I have tried both betas of in_vgm and everytime I play a VGM file (whether it is Master System or Mega Drive), it crashes WinAmp with the Encounter Problem and needs to close message.

The last version, 0.35 worked perfectly but the options screen looks much better on the new one.

Turned out that I had an outdated version of Winamp.
  View user's profile Send private message
DChronos
  • Guest
Reply with quote
Post Posted: Fri Aug 31, 2007 12:20 am
I just discovered Genesis vgm after putting up with crappy gym for so long, but I would really like to be able to adjust the volume boost of overdrive so I can boost it just loud enough so it's not chopping, but not too quiet. And then, aside from that, also have a replay gain feature similar to the SNES Amp lugin to give a bit more of a boost to tracks that aren't loud enough, but not surpassing the overdrive's limit.

Also, I have .34 right now just waiting a bit longer for the finishing touches on .35, and wonder why when I tell it to show only the title, instead, it follows winamp's track labeling scheme no matter what, and doesn't override with the plugin's scheme. Also, is there individula setting for YM2612/2151 or whatever yet?

I was really glad you came along and created this plugin and those other people went through with creating a new format for genesis games. I only read once about it at Zophar's Domain in the news, and never knew if they ever did anything about it. Totally forgot. Nice to see that vgm is still going, even when PS and PS2 seem to be dead now...

Anyway, I also have one last thing to wonder... any way you guys could somehow fix the music bugs that the game engines (GENS, I think I read) were causing so when you record a song like Sonic Spinball's "The Machine", it doesn't have some screwed up instrument sound playing a sound that is not the right one to be played? I have been waiting for a fix for the gym one for years, and find that the vgm version is the same. I got the game, so I know what it should sound like.

Anyway, thanks to all here for keeping the vgm project alive!
 
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13689
  • Location: London
Reply with quote
Post Posted: Fri Aug 31, 2007 8:31 am
DChronos wrote
I just discovered Genesis vgm after putting up with crappy gym for so long


http://project2612.org is the place for Genesis VGMs. It's a little OT here, but discussion of the plugin isn't.

Quote
I would really like to be able to adjust the volume boost of overdrive ... also have a replay gain feature


0.35 fully supports Replay Gain through Winamp's support for it. You have to pre-analyse your music and then it will work identically to Replay Gain with MP3s, etc - all . Due to the large variation (~25dB) in volume even on an original system, per-track and per-pack analysis is the only option apart from an annoying volume control for every track (which wouldn't even be as accurate).

Quote
wonder why when I tell it to show only the title, instead, it follows winamp's track labeling scheme no matter what, and doesn't override with the plugin's scheme


Winamp's ATF formatting will override it. Either disable that or adjust your global title format to work. I have plans in place to be able to customise the data on a level above that, but it's not even started yet. International characters are unlikely to work well if you turn off ATF, proper Unicode support only exists with it turned on.

Quote
Also, is there individual setting for YM2612/2151 or whatever yet?


YM2151: no. YM2612: per-channel enabling, no plans to add fake stereo because it's so prevalent in the original music already.

Quote
any way you guys could somehow fix the music bugs that the game engines (GENS, I think I read) were causing so when you record a song like Sonic Spinball's "The Machine", it doesn't have some screwed up instrument sound playing a sound that is not the right one to be played?


Unlikely. Fixing these kinds of bugs is beyond my capability, and is really only a possibility from the original author of the engine. I am currently adding an alternative YM2612 engine which may help in these cases. However, there so far seems to be no perfect YM2612 emulator, all of them seem to have glitches in some games. The VGM format is slightly inaccurate so you can expect there to be some edge cases it does not handle perfectly too, but I think it's a fair tradeoff.
  View user's profile Send private message Visit poster's website
DChronos
  • Guest
Reply with quote
Post Posted: Sat Sep 01, 2007 12:32 am
Well, that sucks. I wonder why everyone just suddenly stopped working on these projects, aside from the rom thing. By the time that hit, everyone already had them all, pretty much. As for getting the music to play right, someone already pointed out that the cymbals or some specific instrument was the cause of these messed up sounds, so they seem to know plenty about it.

How come someone can't just do to all other roms and rip the music code, then create just a music engine to play? You created one already, so you know a lot about how it works already. Anyone know of anybody that knows about manually ripping music code from games? If you could find the instruments and get those working right, I think all the music will sound right through your plugin.

As for volume boost, SNESAmp supports per track adjustement and does it just fine. Each track has the ability to manually adjust how loud you want it to play, and it has done great for quieter games and tracks. I don't really like the replay gain in SNESAmp due to songs starting off quiet and then just adjusting randomly during songs. A song will be p[laying fine, then get to a louder part that you know is louder, and it will start loud and suddenly get quiet... it throws off the feel of the music.

Anyway, I just want a volume boost adjustment that isn't automatically handled. A solid adjustment like Overdrive just with a volume boost slider, since I prefer all songs stay the same volume I set it at throughout without being too loud or quiet. Is that how it works in yours, though?

Actually, I'll try the newest plugin if you are sure it won't just cause winamp to crash like it did with Yawack. If there's something that causes it that I need to turn off, could you let me know please? Thanks again!
 
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13689
  • Location: London
Reply with quote
Post Posted: Sat Sep 01, 2007 7:45 am
DChronos wrote
How come someone can't just do to all other roms and rip the music code, then create just a music engine to play? You created one already, so you know a lot about how it works already. Anyone know of anybody that knows about manually ripping music code from games? If you could find the instruments and get those working right, I think all the music will sound right through your plugin.


It's very different to what you describe.

Quote
I don't really like the replay gain in SNESAmp due to songs starting off quiet and then just adjusting randomly during songs. A song will be p[laying fine, then get to a louder part that you know is louder, and it will start loud and suddenly get quiet... it throws off the feel of the music.


That's not Replay Gain. Replay Gain uses a psychoacoustic model of "loudness" to remarkably accurately determine how "loud" the original music is, and then adjusts every track to be of equal "loudness". You can apply it on a per-track or per-album (game) basis to allow for dynamic range within a game. It works perfectly to solve this problem as well as the problem of different loudnesses in other music.

Right-click on some VGM music, Send To -> Calculate Replay Gain. Save as Album. Then look for, and enable, Replay Gain in the main Winamp settings. Play -> perfect volume on every track. The only downside is the slow calculation phase, which I tend to do overnight. It only has to be done once for each track.
  View user's profile Send private message Visit poster's website
mic
  • Guest
Reply with quote
Post Posted: Thu Jan 03, 2008 10:52 am
I didn't bother searching through the entire forum so maybe this has been mentioned before, but in_vgm doesn't work on Vista. There is a crash in the plugin before playback has been started (or at least before any sound has been output by winamp).
 
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13689
  • Location: London
Reply with quote
Post Posted: Thu Jan 03, 2008 5:14 pm
There's a crashing problem with 0.35 but I haven't been able to track it down yet. There was a problem with the last.fm plugin but they've fixed it now, and autoupdates ought to have updated it if you use it.
  View user's profile Send private message Visit poster's website
  • Joined: 27 Apr 2005
  • Posts: 420
  • Location: Australia
Reply with quote
Post Posted: Fri Jan 04, 2008 10:58 am
I think you could call this a bug, and I think I know why it's happening.
If you have loop forever set on, and immediate update, and then you go and turn on/off the channel controls, it just stops. Is it because it restarts playback and then seeks to the same spot in playback? (loop forever means no seeking)
  View user's profile Send private message
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13689
  • Location: London
Reply with quote
Post Posted: Fri Jan 04, 2008 12:39 pm
Sounds like a bug :) I'll look into it.
  View user's profile Send private message Visit poster's website
  • Joined: 17 Apr 2007
  • Posts: 120
  • Location: Anchorage, Alaska
Reply with quote
Post Posted: Tue Jan 29, 2008 9:24 am
Would this work directly with GYM, or should I convert the files to VGM?
  View user's profile Send private message
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13689
  • Location: London
Reply with quote
Post Posted: Tue Jan 29, 2008 9:25 am
You should download new VGMs rather than convert from GYM.
  View user's profile Send private message Visit poster's website
  • Joined: 22 Feb 2006
  • Posts: 39
Reply with quote
Post Posted: Fri Apr 25, 2008 12:02 am
Is it possible to lower the volume of the bass instrument on FM playback? I think it's way too loud.
  View user's profile Send private message
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13689
  • Location: London
Reply with quote
Post Posted: Fri Apr 25, 2008 9:39 am
No, it isn't. When you say "bass instrument" do you mean percussion or one of the standard chip instruments?
  View user's profile Send private message Visit poster's website
  • Joined: 22 Feb 2006
  • Posts: 39
Reply with quote
Post Posted: Tue Apr 29, 2008 3:28 pm
I meant chip, the percussion is fine.
  View user's profile Send private message
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13689
  • Location: London
Reply with quote
Post Posted: Tue Apr 29, 2008 4:35 pm
Well, I don't know how to deal with that. I'm using the EMU2413 library which is considered to be pretty good, and I hadn't noticed any instrument imbalances. Can you post some audio files?
  View user's profile Send private message Visit poster's website
  • Joined: 22 Feb 2006
  • Posts: 39
Reply with quote
Post Posted: Tue Apr 29, 2008 7:52 pm
I think it's just too loud overall but some example where it's noticeable are: Bow Wow - Fantasy Zone 2, and Title - Golvellius.
I'm using the same library I think? Just downloaded this and am using it with Winamp.

Maybe this is how FM should sound, but if you could tamper with it manually that'd be pretty cool :)
  View user's profile Send private message
  • Joined: 27 May 2008
  • Posts: 161
Reply with quote
Post Posted: Mon Aug 04, 2008 3:48 pm
When creating a VGM that writes to the DAC with the 0x8n command, the DAC output is silent until the song loops. After that the DAC output works as expected.
This does not happen when using foobar2000's VGM plugin.
  View user's profile Send private message
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13689
  • Location: London
Reply with quote
Post Posted: Mon Aug 04, 2008 4:22 pm
in_vgm has lazy emulator construction and is missing the check in the 0x8n command handlers. I'm guessing you aren't writing to any other registers, so that's a workaround for you until I release a fix.
  View user's profile Send private message Visit poster's website
  • Joined: 27 May 2008
  • Posts: 161
Reply with quote
Post Posted: Mon Aug 04, 2008 5:08 pm
No, after the setup where I enable left and right output for the channels and the DAC I've only got 0x8n-commands.
Would it be enough to insert a dummy write after the first DAC write? Something like this:

8n
52 28 00
8n
8n
8n ...
  View user's profile Send private message
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13689
  • Location: London
Reply with quote
Post Posted: Mon Aug 04, 2008 8:54 pm
Or even before it, yes.

If you can send me a sample file it'll help me test it; the fix seems trivial.
  View user's profile Send private message Visit poster's website
  • Joined: 27 May 2008
  • Posts: 161
Reply with quote
Post Posted: Tue Aug 05, 2008 4:54 am
Here's a test file. It just plays a kick drum sample over and over again.
  View user's profile Send private message
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13689
  • Location: London
Reply with quote
Post Posted: Tue Aug 05, 2008 6:49 am
The sample data block must be earlier in the file than commands using it. That's why it only works after a loop.
  View user's profile Send private message Visit poster's website
  • Site Admin
  • Joined: 08 Jul 2001
  • Posts: 8361
  • Location: Paris, France
Reply with quote
Post Posted: Wed Mar 18, 2009 1:49 pm
I tried to install 0.35 on a new computer I got here and it's crashing after a second when a VGM file is opened (even if it's not playing). Can it be helped, can I provide you more useful information?
The beta from february 2009 works though, but as I understand it it is missing many features.
  View user's profile Send private message Visit poster's website
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13689
  • Location: London
Reply with quote
Post Posted: Wed Mar 18, 2009 1:58 pm
Best to use http://www.smspower.org/maxim/forumstuff/in_vgm_latest/in_vgm_1_last_beta.zip - I forgot what that bug was, but I fixed it.
  View user's profile Send private message Visit poster's website
  • Site Admin
  • Joined: 08 Jul 2001
  • Posts: 8361
  • Location: Paris, France
Reply with quote
Post Posted: Wed Mar 18, 2009 2:24 pm
It is crashing as well :(
Callstack in release mode doesn't seem helpful.
  View user's profile Send private message Visit poster's website
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13689
  • Location: London
Reply with quote
Post Posted: Wed Mar 18, 2009 3:19 pm
Hmm. Is it a old version of Winamp?
  View user's profile Send private message Visit poster's website
  • Site Admin
  • Joined: 08 Jul 2001
  • Posts: 8361
  • Location: Paris, France
Reply with quote
Post Posted: Wed Mar 18, 2009 3:23 pm
5.541, Aug 3 2008
I have then installed the latest, 5.551 and it also crash.
  View user's profile Send private message Visit poster's website
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13689
  • Location: London
Reply with quote
Post Posted: Wed Mar 18, 2009 4:05 pm
Do you have any other non-standard plugins installed? I just reinstalled Winamp, using default options (except for turning off a few extra-annoying things), and it works fine...
  View user's profile Send private message Visit poster's website
  • Site Admin
  • Joined: 08 Jul 2001
  • Posts: 8361
  • Location: Paris, France
Reply with quote
Post Posted: Thu Mar 19, 2009 3:38 am
Maxim wrote
Do you have any other non-standard plugins installed? I just reinstalled Winamp, using default options (except for turning off a few extra-annoying things), and it works fine...

I will try tonight ( in about 8 hours ).
  View user's profile Send private message Visit poster's website
  • Site Admin
  • Joined: 08 Jul 2001
  • Posts: 8361
  • Location: Paris, France
Reply with quote
Post Posted: Thu Mar 19, 2009 6:57 pm
Crash on a clean 5.551
Windows XP SP 3 French
I have VC++ so you can mail me a project or debug binaries if you want.
  View user's profile Send private message Visit poster's website
  • Joined: 27 May 2008
  • Posts: 161
Reply with quote
Post Posted: Wed Aug 05, 2009 6:33 pm
Would it be possible to have a separate preamp for the YM2612 DAC? When listening to a song on a real Megadrive the DAC volume is lower relative to the FM channels than it is when playing the song with in_vgm IMO. With the MAME engine it's waaay too loud, but even with the Gens engine it's too loud, so it'd be nice to be able to adjust the volume.
  View user's profile Send private message
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13689
  • Location: London
Reply with quote
Post Posted: Wed Aug 05, 2009 6:40 pm
I'll add it to the list for in_vgm 2 (due some time in 2012, at the rate I'm going).
  View user's profile Send private message Visit poster's website
  • Joined: 27 Apr 2005
  • Posts: 420
  • Location: Australia
Reply with quote
Post Posted: Wed Sep 02, 2009 12:15 am
Links in the first post are broken because of the music section re-do.
  View user's profile Send private message
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13689
  • Location: London
Reply with quote
Post Posted: Wed Sep 02, 2009 6:37 am
DMEnduro wrote
Links in the first post are broken because of the music section re-do.

Fixed.
  View user's profile Send private message Visit poster's website
Reply to topic



Back to the top of this page

Back to SMS Power!