Forums

Sega Master System / Mark III / Game Gear
SG-1000 / SC-3000 / SF-7000 / OMV
Home - Forums - Games - Scans - Maps - Cheats - Credits
Music - Videos - Development - Hacks - Translations - Homebrew

View topic - SMS Mark 1 Issue

Reply to topic
Author Message
  • Joined: 15 Aug 2019
  • Posts: 55
  • Location: Lancashire UK
Reply with quote
SMS Mark 1 Issue
Post Posted: Tue Apr 06, 2021 8:07 am
Help!
My Master System recently started playing up. After playing for 15-20 minutes or so the signal cuts out and the only way to get it back is turn it off and on again. Weird right!? The power stays on but for some reason after a while of playing it goes to a black screen.

Could it be something simple like dust on the cartridge or something more sinister in the hardware?
  View user's profile Send private message Visit poster's website
  • Joined: 30 Jan 2007
  • Posts: 278
  • Location: San Jose, CA
Reply with quote
Post Posted: Wed Apr 07, 2021 7:49 am
Sounds like the 7805 voltage regulator is overheating, does the 7805 emit a lot of heat after the system shuts down?
  View user's profile Send private message Visit poster's website
  • Joined: 15 Aug 2019
  • Posts: 55
  • Location: Lancashire UK
Reply with quote
Post Posted: Wed Apr 07, 2021 8:38 am
ApolloBoy wrote
Sounds like the 7805 voltage regulator is overheating, does the 7805 emit a lot of heat after the system shuts down?



Hmmmm, interesting. I actually replaced the voltage regulator myself last year. First time doing it so I wonder if that needs looking at again. Thanks for the heads up. I hadn't thought of that. I got it from eBay and used an actual replacement 7805 so shouldn't be the part.

Any suggestions? Should I take out and re-solder. From memory is was a bit of a botch-job tbh. I was just glad the give the old thing some new life.
  View user's profile Send private message Visit poster's website
  • Joined: 30 Jan 2007
  • Posts: 278
  • Location: San Jose, CA
Reply with quote
Post Posted: Wed Apr 07, 2021 5:15 pm
When you replaced the 7805 did you reattach the metal heat sink?
  View user's profile Send private message Visit poster's website
  • Joined: 15 Aug 2019
  • Posts: 55
  • Location: Lancashire UK
Reply with quote
Post Posted: Thu Apr 08, 2021 9:27 am
Yes, I have to say though the soldering wasn't particularly great. That said I was playing sonic and Cali Games last night for a good hour or so and no issues this time. Weird!!

But I wonder if my botched replacement/handy-work is the cause from the glitches. Basically is cuts to a black screen but the power light is still green. Is that what overheating would do?

Or could it all just need repositioning?

I say this because I remember when I re-attached the metal heat sink at first it made the master system cut out and I have to wiggle the VR a little back into position and then try and solder again with the heat sync still attached. (I know, it sounds like a right mess, is isn't great is it).
  View user's profile Send private message Visit poster's website
  • Joined: 30 Jan 2007
  • Posts: 278
  • Location: San Jose, CA
Reply with quote
Post Posted: Thu Apr 08, 2021 10:58 pm
Can you provide pics of your work?
  View user's profile Send private message Visit poster's website
Reply to topic



Back to the top of this page

Back to SMS Power!