Forums

Sega Master System / Mark III / Game Gear
SG-1000 / SC-3000 / SF-7000 / OMV
Home - Forums - Games - Scans - Maps - Cheats - Credits
Music - Videos - Development - Hacks - Translations - Homebrew

View topic - GG Aleste 2 glitch

Reply to topic
Author Message
  • Joined: 01 Feb 2014
  • Posts: 598
Reply with quote
GG Aleste 2 glitch
Post Posted: Tue Feb 02, 2021 2:49 pm
I'm currently having a lot of fun with M2's Aleste collection. In some of my GG Aleste 2 runs, though, I had stage 4 (the desert stage) weirdly glitching out on me. The stage started out perfectly normal, then, a few seconds into the stage, the background graphics and most of the sprites suddenly turned into garbled garbage. Enemy bullets and most enemies weren't affected, so the stage was still playable. The boss was normal and after the stage everything turned back to how it should be.

I asked around a bit and it seems that other people had this exact same thing happening when playing the game via emulation on their PCs. I think this points to it being a bug in the original game. Is this a known bug? I'm curious what might trigger it.
  View user's profile Send private message
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13539
  • Location: London
Reply with quote
Post Posted: Tue Feb 02, 2021 9:43 pm
Can you reproduce it in an emulator with a savestate?
  View user's profile Send private message Visit poster's website
  • Joined: 01 Feb 2014
  • Posts: 598
Reply with quote
Post Posted: Wed Feb 03, 2021 7:58 am
I need to try that. Might take a while, because the glitch only appears at the start of the second half of the game, and I don't know where its seed might be.

In the meantime, if someone wants to see how the glitch looks like, owners of the Aleste collection (Bock?) can download the replay of my all clear run from the game's ranking. (Was at #95 when I did it, I expect it to be a few places lower now.)
  View user's profile Send private message
  • Joined: 01 Feb 2014
  • Posts: 598
Reply with quote
Post Posted: Fri Feb 05, 2021 10:21 am
Unfortunately, I haven't been able tor reproduce the glitch in an emulator yet, but I can now tell exactly at which point in time it happens (if it happens).

Shortly after the beginning of the stage, the tiles in vram that spell the name of the stage "STAGE 4 ANCIENT RUINS" are replaced by the sprite tiles that make up the enemies. When these tiles are loaded, that's the exact point in time the glitch appears.

I suspect there must be some rare condition that causes a wrong address at either the source or the target of the data transfer.
  View user's profile Send private message
Reply to topic



Back to the top of this page

Back to SMS Power!