Forums

Sega Master System / Mark III / Game Gear
SG-1000 / SC-3000 / SF-7000 / OMV
Home - Forums - Games - Scans - Maps - Cheats - Credits
Music - Videos - Development - Hacks - Translations - Homebrew

View topic - devKitSMS and Krikzz MegaEverdrive X7

Reply to topic
Author Message
  • Joined: 09 Jan 2020
  • Posts: 5
  • Location: Brazil
Reply with quote
devKitSMS and Krikzz MegaEverdrive X7
Post Posted: Thu Jan 09, 2020 8:05 pm
Hi guys! My first post here. Thank you very much for your effort to keep SMS legacy alive! I´m a dev from Brazil and willing to contribute as much as I can.

I've done a test rom with a simple splash screen and it runs normally on Kega Fusion, Meka and Emulicious. But when I deploy to Mega Drive thru Krikzz Mega Everdrive X7 the screen flashes for a second and goes black. I followed the coding process from SteveXNA tutorials (which are superb! Congrats dude and thanks!)

There's anything missing in the code or It's an issue regarding Krikzz MegaEverdrive chips?

Cheers all!
  View user's profile Send private message Visit poster's website
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13031
  • Location: London
Reply with quote
Post Posted: Thu Jan 09, 2020 9:27 pm
More likely it's doing something incompatible with a Mega Drive.
  View user's profile Send private message Visit poster's website
  • Joined: 09 Jan 2020
  • Posts: 5
  • Location: Brazil
Reply with quote
Post Posted: Thu Jan 09, 2020 9:37 pm
Weird.. because the 80s and 90s games run normally. Maybe any detail in devkit on how the z80 and genesis vdp are activated or mode4 switch. The worst part is that I don’t have a real SMS hardware nor master everdrive to test ;( Maybe sverx has a workaround. Thanks!

Maxim wrote
More likely it's doing something incompatible with a Mega Drive.
  View user's profile Send private message Visit poster's website
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13031
  • Location: London
Reply with quote
Post Posted: Thu Jan 09, 2020 9:41 pm
The VDP control registers differ between the two so you have to be careful to set any "unused" or "always 1 or 0" bits just right else you may end up activating some Mega Drive feature.

I suspect that devkitSMS is not itself triggering this else every homebrew using it would fail on a Mega Drive. Can you post your source?
  View user's profile Send private message Visit poster's website
  • Joined: 09 Jan 2020
  • Posts: 5
  • Location: Brazil
Reply with quote
Post Posted: Thu Jan 09, 2020 9:47 pm
Sure! Actually there's nothing different I guess... I used your latest version tool (0.43) to convert the graphic (btw very nice tool!). Tiles psgaiden format and tilemap and palettes binary. Thanks again!
main.c (601 B)
main source

  View user's profile Send private message Visit poster's website
  • Site Admin
  • Joined: 19 Oct 1999
  • Posts: 13031
  • Location: London
Reply with quote
Post Posted: Thu Jan 09, 2020 10:01 pm
Well, it looks sensible enough to me... I'll let others have a go.
  View user's profile Send private message Visit poster's website
  • Joined: 09 Jan 2020
  • Posts: 5
  • Location: Brazil
Reply with quote
Post Posted: Fri Jan 10, 2020 3:43 am
I found the problems. First my X7 bios was outdated and the SMS bios was forced to JP. I just set to none and bang. Everything runs fine now.

Once again thank you for your support and patience. I hope pretty soon have something playable to show.

Maxim wrote
Well, it looks sensible enough to me... I'll let others have a go.
  View user's profile Send private message Visit poster's website
  • Joined: 05 Sep 2013
  • Posts: 2563
Reply with quote
Post Posted: Fri Jan 10, 2020 2:51 pm
good you found the culprit :)

a few suggestions:
- you can use assets2banks --singleheader option to have it generate a single header file
- you can load tiles/tilemap/palettes before turning screen on
- STM-compressed tilemaps are perfect for splash screen, and save a lot of ROM

great work so far!
  View user's profile Send private message Visit poster's website
  • Joined: 09 Jan 2020
  • Posts: 5
  • Location: Brazil
Reply with quote
Post Posted: Fri Jan 10, 2020 5:05 pm
Wow! Any suggestion of best practice coming from the lib creator is always considered ;) One last question before living you guys in peace for awhile: about the title/splash screen.. could I do an image DMA display to have access to at least 48 or all 64 colors avaiable? Cheers!

sverx wrote
good you found the culprit :)

a few suggestions:
- you can use assets2banks --singleheader option to have it generate a single header file
- you can load tiles/tilemap/palettes before turning screen on
- STM-compressed tilemaps are perfect for splash screen, and save a lot of ROM

great work so far!
  View user's profile Send private message Visit poster's website
  • Joined: 05 Sep 2013
  • Posts: 2563
Reply with quote
Post Posted: Fri Jan 10, 2020 5:25 pm
You can't display more than 32 colors without changing palette mid-frame, which will likely cause screen artifacts (stray dots) on the screen.

To have 32 colors, you should use both palettes for background, which is possible. Unfortunately, I don't know of any image converter that supports dual palette, so you should probably create two separate images.
  View user's profile Send private message Visit poster's website
Reply to topic



Back to the top of this page

Back to SMS Power!