Forums

Sega Master System / Mark III / Game Gear
SG-1000 / SC-3000 / SF-7000 / OMV
Home - Forums - Games - Scans - Maps - Cheats - Credits
Music - Videos - Development - Hacks - Translations - Homebrew

View topic - Getting Master Everdrive OS v8 working on SEGA MARK III

Reply to topic
Author Message
  • Joined: 04 Dec 2016
  • Posts: 44
  • Location: Guarulhos - SP - Brasil
Reply with quote
Getting Master Everdrive OS v8 working on SEGA MARK III
Post Posted: Tue Jan 31, 2017 1:46 am
After some tests I have found why Everdrive OS v8 fails to Boot on Sega Mark III.
Everdive set !Reset signal to High level on System Power, but as Mark III doesn't have this signal on Slot the !Reset take some time before goes High.
Changing capacitor C18 from 10uF to 0,1uF makes !Reset signal to goes high level fast and this is sufficient to get Everdrive OS v8 booting on a SEGA Mark III

I know this circuit is also called a POR (Power on Reset) and gives some time until system power is stable, but I did not find any issue when changing this.
Tested with regular Japanese and Export Cartridge and they booted fine.



  View user's profile Send private message Visit poster's website
  • Joined: 11 May 2017
  • Posts: 2
Reply with quote
Post Posted: Thu May 11, 2017 9:40 pm
Good Job!! Thanksss
  View user's profile Send private message
  • Joined: 07 Aug 2007
  • Posts: 205
  • Location: Yach, Germany
Reply with quote
Post Posted: Fri May 12, 2017 8:39 am
Possibly related:

In the GG manual, in "precautions for Hardware", section 3, "VDP initialization", a software workaround for a similar issue (VDP still in reset, while Z80 already running) is presented.

Philipp
  View user's profile Send private message Visit poster's website
  • Joined: 20 Jul 2016
  • Posts: 16
Reply with quote
Master Everdrive does not work on Japanese Master System; any software workaround?
Post Posted: Wed May 31, 2017 10:43 pm
I'm extremely bummed to learn that the Master Everdrive does NOT actually work on the Japanese Master System. I bought a Japanese Master System for the FM capability; I bought a US to Japanese adapter from Tototek. I SOLD my US Master System before testing the Everdrive on my Japanese unit.

So in summary, I'm totally screwed. I do not possess the technical capabilities to make any modification to my unit. Is there some sort of software workaround? Do previous versions of the OS work any better?

I'm really angry with stoneagegamer.com, too. They should be warning people that the product does not actually work with the Japanese Master System. I can't be the only one who's bought one expecting it to work.

Thanks, Carl
  View user's profile Send private message Visit poster's website
  • Site Admin
  • Joined: 08 Jul 2001
  • Posts: 8146
  • Location: Paris, France
Reply with quote
Post Posted: Thu Jun 01, 2017 7:09 am
The Master Everdrive works perfectly with the Japanese Sega Master System.

This thread is about the Sega Mark III.
  View user's profile Send private message Visit poster's website
  • Joined: 20 Jul 2016
  • Posts: 16
Reply with quote
Post Posted: Thu Jun 01, 2017 10:51 am
Bock wrote
The Master Everdrive works perfectly with the Japanese Sega Master System.

This thread is about the Sega Mark III.


I had assumed that the Japanese Master System was basically a cosmetic repackaging of the MARK III.

I can assure you that the Master Everdrive does NOT work on my Japanese Master System. I'm investigating the problem, but I can guarantee that the Everdrive does work (tested on the US system), and the Tototek US to Japan adapter should be working as well (I've tried two of them). The Japanese SMS also appears functional.

Anyway, sorry if I went off topic. It was not intentional.

Carl
  View user's profile Send private message Visit poster's website
  • Site Admin
  • Joined: 08 Jul 2001
  • Posts: 8146
  • Location: Paris, France
Reply with quote
Post Posted: Thu Jun 01, 2017 2:28 pm
carljr17 wrote
I can assure you that the Master Everdrive does NOT work on my Japanese Master System. I'm investigating the problem, but I can guarantee that the Everdrive does work (tested on the US system), and the Tototek US to Japan adapter should be working as well (I've tried two of them). The Japanese SMS also appears functional.


It may be a problem with the Everdrive OS version.
Very early versions there was a bug then I helped Kriz fix and it's possible that something else broke as he hasn't really be testing with Japanese SMS.
Do we have an archive of all Everdrive OS version somewhere? We should build one.
  View user's profile Send private message Visit poster's website
  • Joined: 05 Sep 2013
  • Posts: 2586
Reply with quote
Post Posted: Thu Jun 01, 2017 2:51 pm
we could copy what's here: http://krikzz.com/pub/support/master-everdrive/os-bin/ (the mso are just sms ROMs renamed...)
  View user's profile Send private message Visit poster's website
  • Joined: 20 Jul 2016
  • Posts: 16
Reply with quote
Post Posted: Thu Jun 01, 2017 10:15 pm
Bock wrote
carljr17 wrote
I can assure you that the Master Everdrive does NOT work on my Japanese Master System. I'm investigating the problem, but I can guarantee that the Everdrive does work (tested on the US system), and the Tototek US to Japan adapter should be working as well (I've tried two of them). The Japanese SMS also appears functional.


It may be a problem with the Everdrive OS version.
Very early versions there was a bug then I helped Kriz fix and it's possible that something else broke as he hasn't really be testing with Japanese SMS.
Do we have an archive of all Everdrive OS version somewhere? We should build one.


If that's true, I would be happy to update the OS. But with a black screen, I would have no way of maneuvering through the menus to get to the right option to update. Plus, I'm on version 8 of the OS, so if you did have the exact keystrokes, it would have to be for that version of the OS.

Can anyone help me?
  View user's profile Send private message Visit poster's website
  • Joined: 05 Sep 2013
  • Posts: 2586
Reply with quote
Post Posted: Thu Jun 01, 2017 10:24 pm
try this:
- prepare a FAT32 SD card with only two files: the MasterEverdrive OS (ver.8) and a single ROM (you can download an homebrew ROM from this site, I suggest Waimanu SMS of course ;) )
- put the SD card in the Master Everdrive and boot your SMS
- push the 1/START button on the pad once a second for some 20-30 seconds. As there's only one ROM, it should be loaded and started.
If you still can't see anything, you might anyway hear the music, if not, then there are more problems than just resetting the VDP.
  View user's profile Send private message Visit poster's website
  • Joined: 20 Jul 2016
  • Posts: 16
Reply with quote
Post Posted: Thu Jun 01, 2017 10:51 pm
sverx wrote
try this:
- prepare a FAT32 SD card with only two files: the MasterEverdrive OS (ver.8) and a single ROM (you can download an homebrew ROM from this site, I suggest Waimanu SMS of course ;) )
- put the SD card in the Master Everdrive and boot your SMS
- push the 1/START button on the pad once a second for some 20-30 seconds. As there's only one ROM, it should be loaded and started.
If you still can't see anything, you might anyway hear the music, if not, then there are more problems than just resetting the VDP.


I did what you suggested, but still only a black screen and no audio either. :-(
  View user's profile Send private message Visit poster's website
  • Joined: 05 Sep 2013
  • Posts: 2586
Reply with quote
Post Posted: Fri Jun 02, 2017 8:48 am
What happens on your system if you boot up with no cartridge inserted?
  View user's profile Send private message Visit poster's website
  • Joined: 20 Jul 2016
  • Posts: 16
Reply with quote
Post Posted: Fri Jun 02, 2017 11:11 am
sverx wrote
What happens on your system if you boot up with no cartridge inserted?


Works fantastically. I get the "insert cartridge" screen, with a brilliant FM arrangement of the Space Hairier theme. I have every reason to believe the unit works normally, although I do not have any cartridges (either Japan or US) to actually test on it.

Carl
  View user's profile Send private message Visit poster's website
  • Joined: 05 Sep 2013
  • Posts: 2586
Reply with quote
Post Posted: Fri Jun 02, 2017 12:51 pm
so there's a BIOS indeed, which means that there should already be the delay needed before booting a cartridge ROM (as there's no delay in the games code themselves, AFAIK)
So I suspect it's a sort of regional check that fails. You may try the same tests with Everdrive 'older' OSes versions, just remember that SD card should be smaller than 4GB (I suggest using a 2GB) and should be formatted FAT16 in that case.
Also, what happens if you insert the Everdrive with no SD card in it?
  View user's profile Send private message Visit poster's website
  • Joined: 20 Jul 2016
  • Posts: 16
Reply with quote
Post Posted: Fri Jun 02, 2017 9:32 pm
sverx wrote
so there's a BIOS indeed, which means that there should already be the delay needed before booting a cartridge ROM (as there's no delay in the games code themselves, AFAIK)
So I suspect it's a sort of regional check that fails. You may try the same tests with Everdrive 'older' OSes versions, just remember that SD card should be smaller than 4GB (I suggest using a 2GB) and should be formatted FAT16 in that case.
Also, what happens if you insert the Everdrive with no SD card in it?

Nothing happens if I insert the Everdrive without SD card -- same black screen.

So what would be the procedure for downgrading to say, OS 5? Do I put the OS 5 SMS on the SD card first, boot from OS version 8, select upgrade from a menu I can't see (blindly using a sequences of joy pad presses), THEN reformat the card to FAT16, rename file names, etc.

OR do I reformat the card to FAT16, put OS 5 SMS on the newly formatted card, and hope everything takes? (Even though I would presumably be booting in OS 8 mode anyway, which would actually expect FAT32 and not 16).

A bit confused here.

In other words, what are the exact steps to downgrade from OS 8 to OS 5?
  View user's profile Send private message Visit poster's website
  • Joined: 05 Sep 2013
  • Posts: 2586
Reply with quote
Post Posted: Sat Jun 03, 2017 10:34 am
carljr17 wrote
Nothing happens if I insert the Everdrive without SD card -- same black screen.


I just tried on mine (SMS II) with no SD card inserted.
First there's the SEGA logo (this comes from the console BIOS), then the message "OS init..." appears (which comes from EverDrive's firmware), then black screen (as the OS is on the SD, no OS can be loaded)
You're not seeing either the logo or the message, right?
If so, it's useless to try other OS versions, because it seems it doesn't 'boot' at all.

... a problem with some firmware versions (not OS)? I'm speculating.
  View user's profile Send private message Visit poster's website
  • Site Admin
  • Joined: 08 Jul 2001
  • Posts: 8146
  • Location: Paris, France
Reply with quote
Post Posted: Sat Jun 03, 2017 5:11 pm
sverx wrote
First there's the SEGA logo (this comes from the console BIOS),


The Japanese SMS doesn't show a Sega Logo prior to booting games.
  View user's profile Send private message Visit poster's website
  • Joined: 05 Sep 2013
  • Posts: 2586
Reply with quote
Post Posted: Mon Jun 05, 2017 9:27 am
Bock wrote
sverx wrote
First there's the SEGA logo (this comes from the console BIOS),

The Japanese SMS doesn't show a Sega Logo prior to booting games.


OK then. Does "OS init..." appears, then?
  View user's profile Send private message Visit poster's website
  • Joined: 04 Dec 2016
  • Posts: 44
  • Location: Guarulhos - SP - Brasil
Reply with quote
Post Posted: Sun Jun 11, 2017 4:27 pm
sverx wrote

.......
OK then. Does "OS init..." appears, then?


Yes, and then show Files or load the last loaded ROM if no SD Card inserted.
I have a Japanese SMS and it works without any change to Hardware with Master Everdrive OS v8
Neto - Master Everdrive - SMS Jap.jpg (135.28 KB)
Master Everdive OS v8 - Jap SMS
Neto - Master Everdrive - SMS Jap.jpg

  View user's profile Send private message Visit poster's website
  • Joined: 20 Jul 2016
  • Posts: 16
Reply with quote
Post Posted: Mon Jun 12, 2017 11:23 pm
Neto wrote
sverx wrote

.......
OK then. Does "OS init..." appears, then?


Yes, and then show Files or load the last loaded ROM if no SD Card inserted.
I have a Japanese SMS and it works without any change to Hardware with Master Everdrive OS v8


Are you using the converter from Tototek?
  View user's profile Send private message Visit poster's website
  • Joined: 04 Dec 2016
  • Posts: 44
  • Location: Guarulhos - SP - Brasil
Reply with quote
Post Posted: Tue Jun 13, 2017 5:29 pm
carljr17 wrote
...

Are you using the converter from Tototek?


No, mine is the same as shown in this topic http://www.smspower.org/forums/post76573#76573
  View user's profile Send private message Visit poster's website
  • Joined: 30 Jan 2007
  • Posts: 268
  • Location: San Jose, CA
Reply with quote
Post Posted: Wed Jul 26, 2017 3:53 am
I just did the C18 replacement on my Mark III and I can confirm that it works. You don't have to replace it with an electrolytic cap BTW, you can use a non-polarized ceramic 0.1 uF cap and it works just fine.
  View user's profile Send private message Visit poster's website
  • Joined: 25 Nov 2015
  • Posts: 72
Reply with quote
Post Posted: Sat Jan 18, 2020 10:27 pm
Tested and working! Thank you !!
  View user's profile Send private message
Reply to topic



Back to the top of this page

Back to SMS Power!